Unfortunately after uninstalling the Business Objects 4.0 SP6 client and trying to install the new Business Objects 4.1 SP2 client I realized the client can only be installed on a computer with Microsoft Windows 7 SP1 or above

 

I should have checked the SAP PAM (Product Availability Matrix) and I would have realized XP is no longer supports Windows XP http://scn.sap.com/docs/DOC-41355

As you can see Windows XP is no longer mentioned.